PHP 7.4 is now available: use it

joomla support cheshire manchester merseyside north west ukJoomla! 3.9 is compatible with PHP 7.4.

Active developer support for PHP 7.3 ended on 6 December 2020.

Security support for PHP 7.3 will end on 6 December 2021.

SWITCH TO PHP 7.4.

 

More reasons to switch to using PHP 7.4

Using PHP 7.4 with your Joomla! website will help ensure:

  1. improved performance, including page load speed;
  2. significant reduction in memory usage, meaning more users can be served at any one time.

See which versions of PHP are supported.

 

Older versions of Joomla!

If your website is using an earlier version of Joomla! than 3.9 then we recommend that you use the Joomla! Update plugin to update it to the latest available release before switching.

Read more: How to check which PHP version is being used by your Joomla! website.

 

3rd Party Extensions

Check whether any 3rd party extensions used by your website are compatible with a version of PHP before changing.

If your website uses a 3rd party extension that is not compatible with either PHP 7.4 or PHP 8 then use a different extension to avoid increased risk of your website being compromised.

 

Make Joomla! CMS Security YOUR #1 Priority

joomla support cheshire manchester merseyside north west ukWe offer Joomla! coaching, help and support to businesses and organisations across Cheshire, Manchester, Merseyside, North West England & the UK.

Learn how to manage Joomla! website security.