PHP 7.1 is now available

joomla support cheshire manchester merseyside north west uk

PHP 7.1 was released in December 2016.

When PHP 7.0 was released earlier last year we urged users of Joomla! 3.5 (and later) to use it.

So what about PHP 7.1?

The Joomla! Project recommend using either PHP 7.0 or 7.1 for optimal website performance.

And we can confirm, that PHP 7.0 delivers significant improvements in performance for websites using Joomla! 3.5 (and later). Note: 3.5 was superceded a long time ago; always use the latest available release of Joomla! CMS.

We have not seen any evidence that PHP 7.1 offers an additional improvement in performance over and above that achieved when you upgrade your hosting package from PHP 5.6 to 7.0.

Siteground did however recently report that they had successfully tested the core Joomla! CMS (3.6.4 at the time) with PHP 7.1.

There was one caveat, namely that they had not been able to test every available Joomla! extension with the latest version of PHP.

Early adopters of PHP 7.1 should therefore test their Joomla! CMS website and its 3rd party extensions on a development server before going live.

1 Siteground Blog - Dec 2016.

 

So what should you do?

Always use the latest available release of Joomla! and its extensions.

But for now, if your website uses Joomla! 3.5 (or later), stick with using the latest available release of PHP 7.0.

Check that 3rd party extensions used by your website will work with PHP 7.1 before requesting this version of PHP from your hosting provider.

Be aware that:

  • PHP 5.6 will now only receive critical security updates until it reaches its end of life,
  • PHP 5.5 and earlier have reached their end of life and are no longer supported,

Read more: Latest PHP 7 release information.

Read more: Check PHP version using System Information screen.

What if your websites uses Joomla! 3.4 (or earlier)

PHP 7 will break your website, so you may only use the latest release of PHP 5.6.

Upgrade to Joomla! 3.6 (or later) at the earliest opportunity.

There have been several Joomla! security releases since Joomla! 3.6.0 and PHP 5.6 will soon not be supported by the developer community.

Joomla! Technical Requirements

Visit the following link to see which versions of PHP and MySQL are recommended by the Joomla! Project.

Read more: Joomla! Hosting Requirements.

WYNCHCO Joomla! CMS Support

We coach, help and support managers with responsibility for Joomla! websites in organisations across Cheshire, Manchester, Merseyside, North West England & the UK.

Read more: WYNCHCO Joomla! CMS Support Packages.