joomla coach trainer support cheshire manchester merseyside ukSubscribe to WYNCHCO Joomla!® CMS Support

Which version of Joomla!® CMS should you use?

joomla support cheshire manchester merseyside north west ukFirst, NEVER use any version or release of Joomla! CMS, other than the latest published stable version, on a production website.

Reason: more than half of Joomla! releases have historically resulted in improved website security.

Click the link below to find out what is the latest available stable release?

QUICK CHECK: Latest Joomla! Release.

 

Are you using the latest version of Joomla! CMS?

We strongly recommend that you only ever run the latest version or release of the Joomla! CMS and any 3rd party extensions you have installed.

Reasons:

  1. Joomla! 1.0, 1.5 and 2.5 are no longer supported by the Joomla! Project.
  2. The Joomla! Project ended support for the Joomla! 2.5 series on 31st December 2014, meaning no more bug fixes, new features, or security updates.
  3. Joomla! 3.0 series was launched in 2013.
  4. Joomla! 3.9 was released in 2018.
  5. Joomla! 4.0 series was launched on 17 August 2021.

Keep up to date with news about Joomla! CMS and Joomla! extension releases. See links below.

WYNCHCO Joomla! CMS Support

We coach, help and support managers with responsibility for Joomla! websites in organisations across Cheshire, Manchester, Merseyside, North West England & the UK.

Read more: WYNCHCO Joomla! CMS Support Packages.