Joomla! Help Support Warrington Cheshire Manchester Merseyside UK

The Joomla! Project launched its official Extended Long Term Support (ELTS) programme in 2023 to take the pressure off users of website owners using the Joomla! 3.x CMS in the run up to the withdrawal of Joomla! Project security support for the Joomla! 3 Series.

The ELTS is administered by a 3rd party provider and will run for 18 months following the end of Joomla! Project support for Joomla! 3.

Purpose: to provide additional security support for users of the Joomla! 3 CMS.

It is a subscription service.

Read more: The Extended Long Term Support (ELTS) programme (opens in new tab).

Read more: Joomla! Magazine article about the ELTS programme (opens in new tab).

 

Heads Up

The Joomla! Project periodically announce Joomla! 3.10 updates.

The 3.10.15 Security Fix was announced as part of their Joomla! 5.0.3/4.4.3 Security Fix announcement.

But you can check for Joomla! 3,10 ELTS latest releases at the following link:

There follows a list of updates released since the ELTS Programme began.

  • Joomla! 3.10.13 Bug Fix.
  • Joomla! 3.10.14 Security Fix.
  • Joomla! 3.10.15 Security Fix.

Subscription to the ELTS Programme is required if you want to update your website to the latest available release of Joomla! 3.10.

 

Why switch to Joomla! 5 instead of using the ELTS?

The ELTS only provides security support and only for a limited period.

Bug Fix support is excluded.

Support for 3rd party extensions is excluded.

It makes sense to switch to the latest version of Joomla! CMS sooner rather than later.

If you want to switch to using the Joomla! 5 CMS then we can help.

Contact WYNCHCO Customer Support.

 

WYNCHCO Joomla! CMS Support

We coach, help and support managers with responsibility for Joomla! websites in organisations across Cheshire, Manchester, Merseyside, North West England & the UK.

Read more: WYNCHCO Joomla! CMS Support Packages.

Joomla! Help Support Warrington Cheshire Manchester Merseyside UK

The Joomla! Project launched its official Extended Long Term Support (ELTS) programme in 2023 to take the pressure off users of website owners using the Joomla! 3.x CMS in the run up to the withdrawal of Joomla! Project security support for the Joomla! 3 Series.

The ELTS is administered by a 3rd party provider and will run for 18 months following the end of Joomla! Project support for Joomla! 3.

Purpose: to provide additional security support for users of the Joomla! 3 CMS.

It is a subscription service.

Read more: The Extended Long Term Support (ELTS) programme (opens in new tab).

Read more: Joomla! Magazine article about the ELTS programme (opens in new tab).

 

Heads Up

The Joomla! Project periodically announce Joomla! 3.10 updates.

The 3.10.15 Security Fix was announced as part of their Joomla! 5.0.3/4.4.3 Security Fix announcement.

But you can check for Joomla! 3,10 ELTS latest releases at the following link:

There follows a list of updates released since the ELTS Programme began.

  • Joomla! 3.10.13 Bug Fix.
  • Joomla! 3.10.14 Security Fix.
  • Joomla! 3.10.15 Security Fix.

Subscription to the ELTS Programme is required if you want to update your website to the latest available release of Joomla! 3.10.

 

Why switch to Joomla! 5 instead of using the ELTS?

The ELTS only provides security support and only for a limited period.

Bug Fix support is excluded.

Support for 3rd party extensions is excluded.

It makes sense to switch to the latest version of Joomla! CMS sooner rather than later.

If you want to switch to using the Joomla! 5 CMS then we can help.

Contact WYNCHCO Customer Support.

 

WYNCHCO Joomla! CMS Support

We coach, help and support managers with responsibility for Joomla! websites in organisations across Cheshire, Manchester, Merseyside, North West England & the UK.

Read more: WYNCHCO Joomla! CMS Support Packages.